[eMOD] [LH 2.0] XtraDeconstruct: Legacy of Magic (23 August 2016)

§§§ Beyond Legendary Heroes §§§

By on December 31, 2013 1:21:31 PM from Elemental Forums Elemental Forums External Link

Primal_Savage

Join Date 07/2013
+169


  

XtraDeconstruct: Legacy of Magic

by Primal Savage et al.

  

 

1. XtraDeconstruct: Legacy of Magic
1.1 Latest News (Changelog)

(23 August 2016) XtraDeconstruct 2.0.j. - Every Edition is the Last Edition

1.2 Compatibility Snippet (Extended List)

Compatible w/ LH 2.0, all DLC, Children of Storm 1.8.c., Black Market Bazaar 2.0., Champion Bonanza 1.3., and more.

1.3 Features (Extended Description)

Expands LH in a myriad of ways.

1.4 How-to Install (User Guide)

See A_UserGuide.txt

1.5 Endorse XtraDeconstruct (History)

Go to your Nexus Download History to endorse Mods (Thumbs up).

1.6 Download (NexusMods)

Download XtraDeconstruct: Legacy of Magic @ NexusMods (Free). Download page takes 15-20 seconds to load.

 

2. Credits & Feedback

(Hellions) ::: (davrovana) ::: (Heavenfall) ::: (Dhuran) ::: (attackdrone) ::: (Vithar133) ::: (Stardock)

Many users have made valuable contributions to this mod by giving feedback. This is so they realize that their feedback is appreciated.

NOTE: all feedback is valuable, so don't hesitate, but if you would like to answer specific questions, see post #1630.

1720 Replies +6
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
December 13, 2014 6:28:18 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 13, 2014 6:32:42 AM from Elemental Forums Elemental Forums

What is a good site to upload a 226,000,000 Byte file?  I could use my site I have already, but I would have to break it up into 50MB chunks and upload each separately as it doesn't let me upload more than a certain file size.

Reason for Karma (Optional)
Successfully updated karma reason!
December 13, 2014 6:33:24 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 13, 2014 6:43:23 AM from Elemental Forums Elemental Forums

Do you know how much bandwidth you can have per month on Dropbox?

Anyway, I've copied my LHModsDir.7z file to my Dropbox directory.  Now it just needs to upload it.

EDIT: It's only uploading at under 100Kbytes/sec, so it may take 40 minutes or more.

Reason for Karma (Optional)
Successfully updated karma reason!
December 13, 2014 6:51:40 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 13, 2014 6:55:57 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 13, 2014 10:51:23 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 22, 2014 11:27:21 PM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 23, 2014 3:10:51 AM from Elemental Forums Elemental Forums

Really enjoying this so far, but is it your mod that is putting all the extra text and # and stuff all over the place? That is annoying as f*** and makes things ridiculously hard to read! I mean, all the extra details are nice to know, but the labels and such just clutter everything up.  If it's not, disregard, I need to figure out which one is doing this...it's giving me a freaking headache trying to figure stuff out now >.>

Reason for Karma (Optional)
Successfully updated karma reason!
December 23, 2014 11:34:38 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 23, 2014 11:33:44 PM from Elemental Forums Elemental Forums

Yeah, I figured out what most of it meant, it's pretty obvious (meaning, you did a good job that it's easy to figure out what you were going for!), but between those and all the 'title' clutter, like on equipment and whatnot, it just feels bloated, and kinda feels like something went wrong and I have line code errors all over the place.  I'm supposing there's no easy way to turn all of that stuff of, is there?  Like I said, I do like all the added info on everything, just not all that stuff you posted.

 

Regardless, like I said, enjoying the mod so far.  I'm getting a crash every 10 or so turns, but I'm not 100% sure it's your mod, per se, or an incompatibility with another mod (though all the ones I'm using alongside yours are ones you have compat patches for, and I installed them).  I'll dig around and see what's going on.  Smashing job, and nice to see that you're keeping up on it.

 

I went through the "User Guide" and made sure everything was installed properly, too.

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 12:48:42 AM from Elemental Forums Elemental Forums

Is this mod causing the Bonesplinter mount to show two of them, one stacked on top of the other?

 

Also having an issue where the 'Details' screen on a champion is overlayed on the equipment screen.  (I have dual monitors, and for some reason my screenshotting takes it of the monitor I'm NOT using, else I'd take SSs!)

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 12:59:26 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 1:17:18 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 1:53:13 AM from Elemental Forums Elemental Forums

Quoting Primal_Savage,


Quoting Primal_Savage,
Also having an issue where the 'Details' screen on a champion is overlayed on the equipment screen.  (I have dual monitors, and for some reason my screenshotting takes it of the monitor I'm NOT using, else I'd take SSs!)



 

See if you can use the new .dxpack for the UnitDetails. A_UserGuide.txt section:

I. (Optional) - XD_UnitDetailsWnd

 

If that's not possible, try to hide some UnitStats. A_UserGuide.txt section:

O. (Modding) - Hiding/Unhiding Additional Combat Stats [Details/Equipment Screen]

 

Got the Bonesplinter issue fixed, though it didn't make any sense.  I have the DLC2 'fix' for Children of the storm, which apparently had Bonesplinter as one of its fixes.  Removing it from the file removed the double.  Not sure how to fix it otherwise, but that isn't your problem  

I did, actually, I was using the largest version of it.  Now, this was my first time ever actually using the equip screen (normally I'm either in Shop or Trade, which are both fine) so I had no idea if it was a problem on the default.  So I swapped them back (I made backups) and the issue persists.  It isn't bleedover, like what it sounds like you think it is.  It's literally the Details screen on top of the equip screen.

 

Here we go, managed to get a screenshot. 

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 2:11:02 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 4:09:34 AM from Elemental Forums Elemental Forums

Quoting Primal_Savage,

Hum, I'll have a look to make sure the right dxpack is in the zip file, should look like this:

 



 

EDIT: Yep, no issue with the zip files, the right files are packaged:

...\LegendaryHeroes\Mods\XtraDeconstruct\XD_UnitDetailsWnd\1380x1020\

I would try again to copy the 5 files from the folder into 

C:\Program Files (x86)\Steam\steamapps\common\FE Legendary Heroes\screens\

 

EDIT2: Also, Children of Storm files are compatible w/ DLC02 (and DLC03) without the "Children of Storm DLC Item Fix" Mod. That mod is most likely - and at best - redundant.

I deleted both the (core) folder and the 1380 folder, recopied them from the .zip, and then installed the 1380 files into the (core) folder.  Started a new game even, and it is still an issue.  Does it have something to do with the fact I'm using a custom faction/sov?  I made sure to pick all the traits and whatnot that said "take this for customs".

I really appreciate you helping me on this, you rock!

Edit:  Hmm nope, tried loading up one of the default Sovs, does the same thing >.>  Far as I know I'm not using any other mods that would affect the UI; Black Market, Children of the Storm, this one, Patchwork, and then Path of the Ranger/Sorc/Pally.  

Going to do a fresh download and reinstall of all my mods, see what that does.

Edit2: Ok, I'm a tard.  I've been sticking the stupid files in the wrong stupid place.  It's almost 2 in the morning here, I'm tired >.>  Thanks for putting up with my stupidity lol.

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 4:50:11 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 4:51:43 AM from Elemental Forums Elemental Forums

Quoting Primal_Savage,


4. There is a \Screens\ folder in your \Mods\ folder, but that's NOT the one you should be using.

 

Not sure what else...

Yup, that was my problem.  Like I said, lack of sleep make brain go stoophed.  Thanks again! the Details/Equipment screen issue has been fixed.

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 6:02:43 AM from Elemental Forums Elemental Forums

Bahaha.  Now I have another issue.  My trait trees are all FUBAR.

 

For example, look at the Water Magic line.  The basic one is shifted over one spot, and then there is a blank one (it's the one I have highlighted).  The Commander tree looks even worse.

 

Great Administrator is supposed to branch into Great Merchant, Loremaster, and Great Admin2. It also seems to be missing the ability to equip chainmail, but I'm unsure if one of these mods has just removed that.  Not worried about that part.  My trees are just an absolute mess lol.

I tried using the mod that changes the resolution on this (TraitPathDetailsWnd I believe? Sorry again, tired, can't remember, I assume you know which one) and it didn't help - these screenshots are with that mod installed.  In the proper folder this time, of course

Anyway, I'm done putzing with this for the night.  I'll take a look at it with fresh eyes tomorrow, or do whatever you say needs to be done.

I have installed:
Black Market Bazaar

Children of the Storm

This mod

Path of Ranger/Pally/Sorc

Patchwork (installs to the FE /data/English folder, not the mods folder)

All relevant compatibility mods

Followed instructions on removing and/or modifying specific files (like yours, saying to change certain files to .NO)

Female Henchmen 

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 12:37:31 PM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
December 24, 2014 3:14:39 PM from Elemental Forums Elemental Forums

Quoting Primal_Savage,

XtraDeconstruct is not compatible w/ Patchwork. If you remove Patchwork, the trees should be o.k.

 

Ah, good to know, will do that!  Thanks!

Reason for Karma (Optional)
Successfully updated karma reason!
December 31, 2014 11:05:49 PM from Elemental Forums Elemental Forums

Hmm not sure if i installed this mod with the CoS mod incorrect but the centaurs that are in game seem to have the lower half of their body missing (the horse part...)

Reason for Karma (Optional)
Successfully updated karma reason!
January 2, 2015 2:01:55 AM from Elemental Forums Elemental Forums

N/A

Reason for Karma (Optional)
Successfully updated karma reason!
January 2, 2015 5:05:29 AM from Elemental Forums Elemental Forums

Quoting Primal_Savage,

Hey Auggie12,

 

If this is happening when you create a new Centaur Sovereign, then you need not forget to add the Centaur Base (Mount) on creation.

Found in: Appearance > Equipment > Mount (Looks like a yellow warning sign (!)).

 

If this is happening when you create a new Centaur Unit Design, then you need not forget to add the Centaur Base (Mount) on creation.

Found in: Equipment > Mount (Looks like a yellow warning sign (!)).

 

If this is happening when you (or the AI) plays Vini (The original Children of Storm Centaur Sovereign), then I'm not sure what the issue is. Would recommend reinstalling Children of Storm and XtraDeconstruct. Then, make sure the Children of Storm mount file is found where it should be:

ChildrenOfStorm_Shared\COS_mounts.xml

I did the following:

Install CoS - copy all the files into the mod folder

Install XtraDeconstruct - Copied all the files into the mod file. Windows prompted me to override some files which i said yes to.Should i overwrite these files? ( I believe many of the files to be overwritten are from the A_LHLIB_UNITSTAT_BG_VM folder)

Install XtraDeconstruct DLC patches for CoS and other DLCs which i bought.

 

Sounds right?

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #101114  walnut1   Server Load Time: 00:00:00.0000250   Page Render Time: