[Bug][.80] Break Ability Broken

By on April 11, 2013 2:47:55 PM from Stardock Forums Stardock Forums

schattenjaeger

Join Date 04/2008
+2

So, the Assassin's Break ability... it doesn't work.

1) Ability does not apply damage (tooltip says it applies normal damage in the process).

2) Tooltip for enemy hit with ability does not show any reduction in armor. Tooltip for estimated damage does not show any increase.

3) Damage does not appear to be increasing (most pronounced against units with high base armor stat).

Edit: Updated build number because bug still exists.

Locked Post 9 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
April 11, 2013 4:30:28 PM from Elemental Forums Elemental Forums

I can confirm it is not doing the damage, but it appears the defense is being lowered by the appropriate amount. The UI is just not updating the display correctly, but the tool-tip has the correct value. I'll do a further test to see if it is actually reducing the defense appropriately.

But this line needs to be added to do the normal damage (it's missing).

<GameModifier>
            <ModType>Unit</ModType>
            <Attribute>DefendableDamage</Attribute>
</GameModifier>

https://dl.dropboxusercontent.com/u/75549875/Fallen%20Enchantress/Abilities/breakfix.zip

that is a fixed version of the ability. (Updated and is working).

Edit: Confirmed that it is not proprely removing the defense stat with this calculation. Although the tool-tip reads correctly.

Reason for Karma (Optional)
Successfully updated karma reason!
April 11, 2013 4:42:44 PM from Elemental Forums Elemental Forums


Found the error... mis spelling

<StrVal>UnitStat_Defense_Pierce</StrVal>

You had before

<StrVal>UnitStat_Defense_PIerce</StrVal>

Reason for Karma (Optional)
Successfully updated karma reason!
April 11, 2013 5:08:04 PM from Stardock Forums Stardock Forums

Those damnable spelling errors!

This is to go in CoreSpells? (I hope so 'cause that's where I put it = P)

Reason for Karma (Optional)
Successfully updated karma reason!
April 11, 2013 5:17:00 PM from Elemental Forums Elemental Forums

No just put it in your documents folder mods and you can then run mods... it will take care of the problem.

If you really don't want to click the option mods, then stick the file in the items folder under documents.

...\documents\my games\Legendary Heroes\mods\

or

...\documents\my games\Legendary Heroes\items\

If in the mods folder you need to tick use mods option in game.

Reason for Karma (Optional)
Successfully updated karma reason!
April 12, 2013 3:51:31 PM from Stardock Forums Stardock Forums

Placed file in Mods folder, ticked Use Mods, no change. Still not doing damage or reducing defense.

Moved to Mods\Data, no change.

Moved to Items, no change.

Going to go edit the core file and see if that works.

Edit: No dice.

Reason for Karma (Optional)
Successfully updated karma reason!
April 12, 2013 4:46:41 PM from Elemental Forums Elemental Forums

You do need to add this line also if you edit the core files.

<GameModifier>
   <ModType>Unit</ModType>
   <Attribute>DefendableDamage</Attribute>
</GameModifier>

Plus are you unzipping the file to have just the xml in your mods folder. Mind you I only tested this with ranged units... so it might be something with non-ranged items causing a problem.

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
April 12, 2013 4:50:08 PM from Elemental Forums Elemental Forums

When applying mods you have to turn mods on in the game options and start a new game for the mod to apply.

Reason for Karma (Optional)
Successfully updated karma reason!
April 12, 2013 4:56:37 PM from Elemental Forums Elemental Forums

Quoting DsRaider,

When applying mods you have to turn mods on in the game options and start a new game for the mod to apply.

Oh yeah... that too... whenever you edit any of the files because the save game collects all the xml data and doesn't update it.

Reason for Karma (Optional)
Successfully updated karma reason!
April 12, 2013 10:34:18 PM from Stardock Forums Stardock Forums

Quoting DsRaider,

When applying mods you have to turn mods on in the game options and start a new game for the mod to apply.

Good to know!

To elaborate: Yes, Parrot, I unzipped the file = P And when I edited the Core file, I did a straight copy-paste from your fix (I've done enough programming that I knew what to do with that = P). Did not know about the new game factor, though.

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #101114  walnut1   Server Load Time: 00:00:00.0000078   Page Render Time: