Start-up Crashes? nVidia or ATI card in your laptop? See here.

By on March 7, 2013 12:51:04 PM from Elemental Forums Elemental Forums

CharlesLentz

Join Date 08/2006
+39

First off, always make sure you have the latest drivers for your particular card.  You'd be amazed at the number of crashes that are "fixed" by having the player update his gfx card drivers.

Having said that, recently we've gotten a few reports from people who have just downloaded the game for the first time, and get a crash upon trying to start it.  It a lot of cases they have an nVidia card in their laptop with a technology called Optimus.  This tech basically tries to be smart enough to determine if you really need to use the nVidia card, like for a gfx-intensive task (ie. gaming), or if it could switch to an embedded intel card, for battery savings (for example if you're just checking your email).  It switches automatically based on what it decides when you fire up an application.

As you might imagine, when things are automated, they don't necessarily always work the way you expect.  Luckily in this case, there is a way to force it to always use the nVidia card for FE/LH.

Instructions:
-Open the "NVIDIA Control Panel" from your start menu.
-On the left, under "Select a task...", open the "3D Settings" tree, and select "Manage 3D Settings".
-Now on the right panel, click the "Program Settings" tab.
-Under "1. Select a program...", click "Add", navigate to wherever your game is installed at (commonly C:\Program Files (x86)\Steam\steamapps\common\Elemental Fallen Enchantress\ ) and select "FallenEnchantress.exe".
-Under "2. Select the preferred graphics...", choose "High-performance NVIDIA processor", then click "Apply" in the bottom right.

NOTE: I found these instructions by using google.  Your exact steps may differ, but should be similar enough for you to figure out what you need to do.

Locked Post 2 Replies +1
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
March 8, 2013 7:22:22 AM from Elemental Forums Elemental Forums

This helps even though I don't have this problem myself. I was running into the problem that my NVidia card wasn't kicking in which it should have. Knowing where this option is helps a lot. 

Reason for Karma (Optional)
Successfully updated karma reason!
July 11, 2013 3:15:44 PM from Elemental Forums Elemental Forums

I have found that people with ATI cards have similiar issues.  

ATI has a technology called ATI PowerPlay, which is the same as nVidia Optimus, but ATI's version.  Again, it is a battery-saving technology meant to switch back and forth between the good gfx card (for gfx-intense tasks) and an onboard card (for 2D stuff, which uses less battery).  It can cause the same issues with start-up crashes.  If you are having such and issue, you need to go into your settings and either turn this automatic switching off, or add the game to the list of exe's that ALWAYS use the good gfx card.

Here's some instructions I found for turning it off:

http://www.ehow.com/how_8550663_disable-ati-powerplay.html

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0000109   Page Render Time: