Custom Content

By on November 14, 2012 6:50:31 PM from Elemental Forums Elemental Forums

Darkranger85

Join Date 09/2009
0

Hey all,

 

I'm looking for a guide on how to add a few things into the game, namely custom logos and races.

I know you can make a new faction, but I also want to be able to choose a race of my liking.

As far as the logos, I found the folder they are in and made a logo of the same size and format but it doesn't show up in the game, I'm assuming because you need to alter an xml file or something.

Any help would be awesome!

Thanks

Locked Post 12 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
November 14, 2012 7:08:44 PM from Elemental Forums Elemental Forums

Making new races is very complicated, especially if you want them to look unique. Here is an editor that allows you make basic new races.

Yes to add custom logos you have to edit xml. If it's on a custom faction that faction file can be found in MyDocuments/MyGames/FallenEnchantress/Race. You will want to add your custom logos to the /FallenEnchantress/Mods/GFX folder.

The tag you edit to change a faction logo is <PreferredLogoType>Your LogoName</PreferredLogoType>

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2013 9:49:32 AM from Elemental Forums Elemental Forums

I followed those instructions but the custom logo refuses to appear

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2013 10:09:11 AM from Elemental Forums Elemental Forums

The information above is for adding a logo to an already existing faction.

If you want a custom logo to appear in the editor take a look at...

Stardock Games\FallenEnchantress\data\English\CoreLogos.xml

again the custom logo picture has to be in the mods/Gfx folder and it's usually a better idea to not directly edit the xml files in \data\English. Instead copy any changes into a new file to be placed into

Documents\My Games\FallenEnchantress\Mods

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2013 10:48:42 AM from Elemental Forums Elemental Forums

Yeah i noticed its for already existing factions but still cant make it work. I followed your new instructions for to add logos appear in the edit and no luck.

Definitely i am doing something wrong 

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2013 11:06:52 AM from Elemental Forums Elemental Forums

You could paste your code. Do you have .png after the picture name and is it saved as a png file?

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2013 11:21:42 AM from Elemental Forums Elemental Forums

Yes i added the .png at the end.

i entered:

<LogoType InternalName="Dagger">
    <DisplayName>Dagger</DisplayName>
    <Description></Description>
    <MainLogo>Dagger.png</MainLogo>
  </LogoType>

in the bottom of the CoreLogos before the end (Dagger is the name of the png file)

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2013 12:22:35 PM from Elemental Forums Elemental Forums

are you talking about faction crests?

Try using the mod folder instead of altering the core file, like DsRaider suggested.  Don't forget to enable Use Mods in the game options.

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2013 12:34:42 PM from Elemental Forums Elemental Forums

If what mqpiffle says doesn't work then do you have all the needed tags? FE Xml data usually has tags on the top and bottom of the data like so.

<LogoTypes>

<LogoType InternalName="Dagger">
    <DisplayName>Dagger</DisplayName>
    <Description></Description>
    <MainLogo>Dagger.png</MainLogo>
  </LogoType>

</LogoTypes>

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2013 1:24:38 PM from Elemental Forums Elemental Forums

The use of mods is enabled in the game options, and i am quite sure that the tags are correct. Just in case i ve done it wrong from start the logo i am adding is in: MyDocuments/MyGames/FallenEnchantress/Mods/Gfx/dagger.png and then i opened the xml to add the logo in the custom race typing <PreferredLogoType>dagger.png</PreferredLogoType> . When i start the game the faction logo is blank.

Now about adding logos in the race editor i followed your advice and maked another copy of CoreLogos and placed it in the MyDocuments/MyGames/FallenEnchantress/Mods/ and added in the last line the code i pasted above.

I am sure the mistake is entirely on me

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2013 2:08:43 PM from Elemental Forums Elemental Forums

OK after some experimenting I got this to work on my end. What you have to do is do both and insert the internal name of the logo.

<LogoTypes>

<LogoType InternalName="Dagger">
    <DisplayName>Dagger</DisplayName>
    <Description></Description>
    <MainLogo>Dagger.png</MainLogo>
  </LogoType>

</LogoTypes>

Then

<PreferredLogoType>Dagger</PreferredLogoType>

no .png here

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2013 2:37:07 PM from Elemental Forums Elemental Forums

It worked finally. Thanks for all your help and your time DsRaider 

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
March 28, 2013 4:57:56 AM from Elemental Forums Elemental Forums

I get to keep the rest of my hair, thankfully. Good old search saved the day. Behold my logos appear! Thanks guys.

 

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0000563   Page Render Time: