[0.802][Bug/Gameplay] Can't finish turn

By on June 17, 2010 9:55:02 PM from Elemental Forums Elemental Forums

Jono_Oko

Join Date 02/2010
0

The "next turn" button is grayed out. Here is a link to a save a couple turns before it inevitably happens..

http://dl.dropbox.com/u/8214734/next%20turns.EleSav

I though it was because I was attacking an AI city, but the problem happens even if I don't attack it. I have no idea what causes this...

Locked Post 11 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
June 18, 2010 1:01:32 AM from Elemental Forums Elemental Forums

Was it turn 200? I noticed the game ends on turn 200.

Reason for Karma (Optional)
Successfully updated karma reason!
June 18, 2010 2:34:40 AM from Elemental Forums Elemental Forums

I'm on turn 521, and in beta 2 got to ~1000 turns.

I did get the 'can't end turn bug' just now, first time in Beta 2.  Nothing I did, noticed nothing, that may have caused it.  Nothing I did got the turn to end.

Save

Reason for Karma (Optional)
Successfully updated karma reason!
June 18, 2010 12:36:17 PM from Elemental Forums Elemental Forums

I was on turn ~250. I won another game after >1000 turns without any problems.

Reason for Karma (Optional)
Successfully updated karma reason!
June 18, 2010 3:45:35 PM from Elemental Forums Elemental Forums

Are you guys using the auto turn option?

Reason for Karma (Optional)
Successfully updated karma reason!
June 18, 2010 5:40:01 PM from Elemental Forums Elemental Forums

No auto turn. I wonder if it could be because of the high level critters roaming next to my cities attacking a caravan for example. I will test that tonight.

Reason for Karma (Optional)
Successfully updated karma reason!
June 18, 2010 9:40:36 PM from Elemental Forums Elemental Forums

Really, I swear that all my games just greyed out the turn button on 200 for me. Huh.

Reason for Karma (Optional)
Successfully updated karma reason!
June 20, 2010 1:45:28 AM from Elemental Forums Elemental Forums

I got the same in .803.

Reason for Karma (Optional)
Successfully updated karma reason!
June 20, 2010 6:24:27 AM from Elemental Forums Elemental Forums

This is very game breaking.

I can post my save if it's necessary?

Reason for Karma (Optional)
Successfully updated karma reason!
June 20, 2010 6:46:50 AM from Elemental Forums Elemental Forums

I had this two times in mine. Once was a caravan that got stuck, confused, whatever. I disbanded it and it worked.

the other was a transport. I didn't more it and I think it was autoexploring, but then ran out of things to explore or whatever. I moved it and then could end the turn.

Reason for Karma (Optional)
Successfully updated karma reason!
June 20, 2010 9:12:37 AM from Elemental Forums Elemental Forums

Quoting Blaze of Glory,
I had this two times in mine. Once was a caravan that got stuck, confused, whatever. I disbanded it and it worked.

the other was a transport. I didn't more it and I think it was autoexploring, but then ran out of things to explore or whatever. I moved it and then could end the turn.
This sounds like the bug I reported here  -- a transport's path was blocked and it stopped, and the turn couldn't be ended until the transport was directed around the blockage.

Reason for Karma (Optional)
Successfully updated karma reason!
June 20, 2010 5:01:03 PM from Elemental Forums Elemental Forums

Quoting Blaze of Glory,
I had this two times in mine. Once was a caravan that got stuck, confused, whatever. I disbanded it and it worked.

the other was a transport. I didn't more it and I think it was autoexploring, but then ran out of things to explore or whatever. I moved it and then could end the turn.

That was it. Thank you very much. +karma

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0000125   Page Render Time: