How do I embed a video?

By on January 20, 2010 6:45:54 AM from Elemental Forums Elemental Forums

xGhost4000x

Join Date 01/2010
+12

Please and Thank you.

+1 Karma to first answer, accurate answer.

Locked Post 19 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 10:35:49 AM from Elemental Forums Elemental Forums

Well, I know how to copy & paste embed tags from YouTube, but that doesn't seem to work on these boards via FireFox.

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 10:38:18 AM from Elemental Forums Elemental Forums

Oh so I should just use a different browser or IE Tab, thanks!

Hmm, no go on IE Tab or Google Chrome.

Never mind, I hadn't been using a code block.

Never mind again, I had thought the code block would work but it humorously only works when I'm creating the post, not after I post it.

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 11:03:01 AM from Elemental Forums Elemental Forums

And I finally got it working, I have to edit the HTML directly and add proper opening and closing tags before the video.

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 11:05:01 AM from JoeUser Forums JoeUser Forums

Also it helps to strip down the embed code that you get from the site and only use the embed key itself without termination.

The forum software will actually provide everything else.

For example the following clip.

 

The following is the embed code provided by youtube with the angle brackets replaced with curly brackets so that the code is not interpeted.

{object width="425" height="344"}{param name="movie" value="http://www.youtube.com/v/vWLfUvTfTHo&hl=en_US&fs=1&"}{/param}{param name="allowFullScreen" value="true"}{/param}{param name="allowscriptaccess" value="always"}{/param}{embed src="http://www.youtube.com/v/vWLfUvTfTHo&hl=en_US&fs=1&" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"}{/embed}{/object} 

So all you do is "Edit HTML Source" and paste in the above and delete all but the following tag and the forum software will provide the rest. Nost that in this case the src= term appears first but that doesn't matter just copy the embed tag and the embed tag *only*.

{embed src="http://www.youtube.com/v/vWLfUvTfTHo&hl=en_US&fs=1&" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"}

One other caveat emptor is that it is sometimes dependent on the browser that you're using. At home this works for me with FF and not IE7 but at work it works with both. YMMV

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 4:29:53 PM from JoeUser Forums JoeUser Forums

Quoting GW Swicord,
Well, I know how to copy & paste embed tags from YouTube, but that doesn't seem to work on these boards via FireFox.

Write your narrative, then click on the HTML button.  Copy and paste the string from youtube (hulu or whatever) and then click update.  Viola!

 

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 5:01:41 PM from Demigod Forums Demigod Forums

Mumblefratz: If I wanted to embed an swf, is there any way I could bypass the ActiveX control bloxx in Internet Explorer. I'm making a website with an animated header, but on certain versions of IE, it won't load until you give it permission.

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 6:27:50 PM from JoeUser Forums JoeUser Forums

Mumblefratz: If I wanted to embed an swf
Sorry but my expertise is in hardware not software, what little I know about html and activex could be summarized by the phrase "avoid whenever possible".

There used to be a number of software folks around but not so much these days. I'm not sure what your home site is and what forums that you normally have access to but the Personal Computing forum is a good place to ask this kind of a question. Also the WinCustomize site seems to have a lot of software types that could probably answer this for you.

Finally I think Kryo would know the answer and if the answer isn't too long he probably wouldn't mind answering a PM about it but might get annoyed if the answer ended up being complicated.

I'd say try each of these things in the order I listed and you should get a good answer somewhere along that path.

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 6:35:14 PM from Demigod Forums Demigod Forums

Thanks for your help.  

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 6:47:36 PM from GalCiv II Forums GalCiv II Forums

Quoting Splitshadow,
Thanks for your help.  
You're very welcome.

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 6:50:45 PM from Elemental Forums Elemental Forums

Now I don't feel like quite such a fool...

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 7:05:18 PM from JoeUser Forums JoeUser Forums

No matter how much things change they always stay the same.

 

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2010 8:10:12 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

lol

Reason for Karma (Optional)
Successfully updated karma reason!
February 13, 2011 9:46:41 PM from Stardock Forums Stardock Forums

Quoting xGhost4000x,
And I finally got it working, I have to edit the HTML directly and add proper opening and closing tags before the video.

 

Care to share those tags w/ me?  I'm having trouble embedding now.

Reason for Karma (Optional)
Successfully updated karma reason!
February 13, 2011 9:54:15 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

If embedding from YouTube make sure you select "Use old embed code"

Reason for Karma (Optional)
Successfully updated karma reason!
February 13, 2011 11:59:54 PM from Demigod Forums Demigod Forums

In case someone hasn't posted this, drjbhl created a current guide on it:

http://drjbhl.impulsedriven.net/article/404889/How_To_Embedding_Videos_and_Posting_Pictures

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 14, 2011 1:07:45 PM from GalCiv II Forums GalCiv II Forums

Thanks.

Following that link OMG,  I was able to get it done following drjbl's instructions.


But....only with IE was it possible.  I use firefox but not sure if other firefox users also had troubles.

-.-

Reason for Karma (Optional)
Successfully updated karma reason!
February 14, 2011 2:22:13 PM from Stardock Forums Stardock Forums

But....only with IE was it possible. I use firefox but not sure if other firefox users also had troubles.

those instructions worked for me in firefox.

Reason for Karma (Optional)
Successfully updated karma reason!
February 15, 2011 3:26:35 PM from GalCiv II Forums GalCiv II Forums

Quoting OMG_pacov,

But....only with IE was it possible. I use firefox but not sure if other firefox users also had troubles.
those instructions worked for me in firefox.

That's interesting..  I have the lava theme for ff..not sure if that would make a difference.

-.-

Reason for Karma (Optional)
Successfully updated karma reason!
February 17, 2011 8:54:52 AM from JoeUser Forums JoeUser Forums

Quoting OMG_pacov,

But....only with IE was it possible. I use firefox but not sure if other firefox users also had troubles.
those instructions worked for me in firefox.

Ditto.

I guess the question is what addons do you have in FF?  I have found some to be problematic (like the Fastestfox one).  It does what it proclaims, but some web pages are not designed for that feature and do not work with it.

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #101114  walnut1   Server Load Time: 00:00:00.0000141   Page Render Time: